NIS Mail NECカスタマーサポート
  ログイン
SUPPORT MENU

■ TOP
dotline
■ 製品関連情報
dotline
■ バージョン情報
dotline
■ Q&Aコーナー(FAQ)
dotline
■ テクニカルサポート情報
dotline
■ ダウンロードサービス
dotline
■ 更新履歴
dotline
■ パスワード変更
navi_bottom

navi_top

ご不明な点がありましたらサポート窓口までご連絡ください。

nismail@nis.jp.nec.com
navi_bottom
テクニカルサポート情報

095. SV共通 サーバ間転送機能(SCC)で内部プロセス間通信失敗が発生した場合、データロストが発生する場合がある

----
この資料は以下の製品について記述したものです。
  • NISMAIL/UX Version 1.0 Release 1.0~Version 4.0 Release 2.8
  • NISMAIL/NT Version 1.0 Release 1.0~Version 3.0

概要

サーバ間転送機能(SCC)で内部プロセス間通信失敗が発生した場合、データロストが発生する場合がある

詳細

本現象は内部プロセス間通信(*1)ができない異常な環境で発生します。

NISMAILではデータ転送時にサーバ間転送メッセージ管理プロセス(SCCM)からサーバ間転送プロセス(SCCS)へ転送要求メッセージを内部プロセス間通信を用いて送信します。内部プロセス間通信ができない場合やSCCSプロセスが異常終了している場合(*2)、転送要求メッセージの送信に失敗します。

現象発生時には以下のメッセージが10回出力されます。
EC,14101,SCCM,14101 :Unable to send message to SCCS [308][238]

上記のSCCMからSCCSへの転送要求メッセージの送信失敗時には10回までリトライしますが、リトライオーバした場合は転送要求メッセージを破棄してしまいます。この転送要求メッセージの破棄によってファイルのロストが発生します。

(*1)内部プロセス間通信について

NISMAILはNISMAILのプロセス間の通信をTCP/IPのソケット通信で行っています。内部プロセス通信はlocalhostへの接続によって実現しており、内部プロセス通信に失敗した場合は以下のlocalhostへの接続失敗メッセージが出力されます。

・localhostに対しての接続失敗メッセージ
WC, 14073,SCCS ,14073 :Abnormal server connection [tcp_new_client][localhost][9005][238]

本メッセージは今回の現象以外にもマシン負荷等で発生することがあります、数回の出力であればリトライ処理によって正常に処理されているので問題ありません。

(*2)関連公開資料

 

 

対策

・応急対応
NISMAILをウォームモードで再起動した後、ロストしたファイルを業務的に確認し、再度NISMAILへ投入してください。

・恒久対応
NISMAIL/UX Version 5.0 Release 1.0以降・NISMAIL/NT Version 4.0 Release 1.0以降で本現象に対応しております。
対応内容は、リトライオーバした場合に転送要求メッセージを破棄せずに、サーバ間転送メッセージ管理プロセス(SCCM)を強制的に終了するように修正が入っております。
NISMAILのウォームモードによる再起動によって転送要求メッセージが正常に復元されますのでファイルロストは発生しません。

状況

弊社ではこの問題をNISMAILの問題であると認識しております。
NISMAIL/UX Version 5.0 Release 1.0以降で修正済みです。
NISMAIL/NT Version 4.0 Release 1.0以降で修正済みです。


line

・ この資料の内容は予告なしに変更されることがあります。
・ いかなる場合でも、この資料の内容およびその運用の結果に関しては一切の責任を負いません。
・ この資料に記載されている会社名、製品名は、各社の登録商標または商標です。

NEC


back pagetop

footerline
Copyright © NEC Corporation 2026. All rights reserved.