|
サーバ自身のホスト名が32バイトを超えていると、管理コンソールからログイン時に
エラーとなります。
この際、管理コンソール側は以下の内容のポップアップが出力されます。
Linux、HP-UX OS上のNISMAILサーバ製品への接続の場合
クライアントエラー
(Err:1000)
詳細コード1:11302111
詳細コード2:100000
詳細コード1:0
Windows OS上のNISMAILサーバ製品への接続の場合
クライアントエラー
(Err:1000)
詳細コード1:11302111
詳細コード2:-1
詳細コード1:10054
サーバ側のNISMAIL Listenerのログには以下のメッセージが出力されます。
Linux、HP-UX OS上のNISMAILサーバ製品への接続の場合
YYYY/MM/DD hh:mm:ss : nnnnnnnnnn : Request failure [xxx.xxx.xxx.xxx][][2000][203103][-1][36]
|
Windows OS上のNISMAILサーバ製品への接続の場合
YYYY/MM/DD hh:mm:ss : nnnnnnnnnn : Request failure [xxx.xxx.xxx.xxx][XXXX][2000][203103][-1][10014]
|
NISMAIL Listenerでは、管理コンソールからの接続時に実行される
処理内でgethostname()関数を利用しホスト名を取得しています。
ホスト名は31バイトまでとしており、gethostname()関数で抽出した
ホスト名が32バイト以上の場合はエラーとしております。
この為、ホスト名が32バイト以上のNISMAILサーバに管理コンソールで
接続すると、NISMAIL Listenerではホスト名取得が異常となり、
管理コンソールへの応答が返せなくなります。
管理コンソールでは、接続に対する応答が無い為、接続エラーとなります。
gethostname()関数の動作はOSに依存しており、windowsとLinuxでは
ホスト名が31バイトまでとなりますが、HP-UXでは32バイト迄エラー
となりません。
なお、管理コンソールのみ本エラーが出力されており、NISMAIL Listenerに
ログが出力されていない場合は、管理コンソールがNISMAIL Listener以外の
ポートに接続を行っております。
この場合は管理コンソールに設定しているポートを修正してください。
NISMAILサーバのホスト名を31バイト以下に設定願います。
gethostname()関数は、ローカルマシンのホスト名を取得しており、
hostsファイルの内容を変更しても回避されません。
弊社ではこの問題をNISMAILの問題と認識しております。
この問題は以下のバージョンで修正済みです。
- NISMAIL/UX(HP-UX版 IPF対応) Version 7.0 Release 5.0
- NISMAIL/Linux(x64版) Version 7.0 Release 5.0
- NISMAIL/NT(x64対応) Version 7.0 Release 5.0
- NISMAIL/AD(Linux) Version 7.0 Release 5.0
- NISMAIL/AD(Windows) Version 7.0 Release 5.0
|