|
Windows Server 2012環境においてNISMAILサービスを「対話型サービス」として起動しても、
コマンドプロンプトが起動されずにイベントログに以下のエラーが出力されます。
「NISMAIL_XXサービスは、対話型サービスとしてマークされています。しかし、システムは対話型サービスを
許可しないように構成されています。このサービスは正常に機能しない可能性があります。」
※ NISMAIL_XXはインストール時に設定したインスタンス番号となります。
Windows Vistaより前にリリースされたWindowsシステムはコンピュータにログオンした最初のユーザはセッション0で
実行されていました。しかし、Windows Vista以降にリリースされたシステムでは、セキュリティの観点からサービスと
ユーザアプリケーションが別のセッションで実行される仕組みとなりました。これはセッション0の分離と呼ばれております。
Windows Server 2012では規定値として、セッション0環境で、ユーザアプリケーションを実行することが許可されておりません。
「対話型サービス」はセッション0で動作しようとする為、実行することが許可されずにエラーとなります。
本件につきましては、Windowsの仕様変更に伴い制限事項とさせていただきます。
Windows Server 2012環境においては、NISMAILサービスを「対話型サービス」として起動
しないようにご注意ください。
|