|
概要
Windows Server 2003にService Pack 1およびService Pack 2を適用することにより、OSの動きが一部変更となるためサーバ間転送機能(以下、SCC)に影響が出ることがあります。
詳細
ソケットに高い負荷が掛かっている状態でSCCを運用した時に、TCPセッションが強制切断されることで、以下の現象が発生する可能性があります。
- 転送が異常終了する
- 送信側と受信側で転送ステータスの不一致が発生する
例)送信側:「転送中」 受信側:該当なし
送信側:「異常終了」 受信側:「転送済み」 など
- 以下の内容がメッセージログに出力される
|
EC, 14074,SCCS ,14074 :SEND異常 [tcp_ikeike][12][10054]
EC, 14007,SCCS ,14007 :タイマー処理 トーナメント要求失敗[10054]
EC, 14074,SCCM ,14074 :SEND異常 [tcp_ikeike][308][10054]
EC, 14101,SCCM ,14101 :対SCCSメッセージ送信失敗 [308][10054]
|
この現象は、Windows Server 2003 Service Pack 1から変更になったネットワークセキュリティの設定の一つとなる「SYN攻撃からの保護が既定で有効」が原因と確認しております。
この設定により、高負荷時のSCCにおいて接続は成功しても、その後の送受信でエラーが発生し各問題が起こる可能性があります。
本現象はOSの開発元となるMicrosoft社へ確認済みです。
対策
Versionによって対応方法が異なります。
状況
弊社ではこの問題をOSの互換性問題であると認識しております。
なお、この問題は以下のバージョンで対応済みです。
- NISMAIL/NT Version 5.0 Release 3.5、Version 6.0 Release 1.1
- NISMAIL/NT(IPF対応) Version 5.0 Release 3.5
|