概要
NISMAIL FTPサーバに対し、FTPクライアントから「putコマンド」や「getコマンド」を実行した際に、以下のエラーが発生し、転送要求を受け付けない場合があります。
| <エラー内容> 550
x:\nismail\FILES/SYSF1/FLSF: Permission denied. |
詳細
NISMAIL FTPサーバは、FTPクライアントから「putコマンド」や「getコマンド」の要求時に、NISMAIL定義ファイル(FLSF)をオープンします。
その際、このファイルのオープン方式に誤りがあり、NISMAIL上の他の処理(*1)とオープンが重なるとごく稀なタイミングで権限エラーが発生します。FTPサーバで本エラーが発生すると、上記エラーメッセージがFTPクライアントに返却され、ファイル転送に失敗します。
(*1) クライアント・コントロールパネル、クライアント・コントロールパネル2からの定義や状況表示など。
対策
・応急処置
上記エラーが発生した場合、FTPクライアントから、「putコマンド」、「getコマンド」を再実行して下さい。その際、FTPサーバ上への状態変更などは必要ありません。
・恒久対応
本件について修正物件(*2)を準備しておりますので、修正物件申込書にてお申し込みください。
(*2) 対応バージョン:NISMAIL Version 4.0 SP1以上(Version 4.0 Release 2.8相当)
状況
弊社ではこの問題をNISMAILの問題であると認識しております。
なお、この問題はVersion 5.0 Release 3.1で修正済みです。
|