概要
次のメッセージが出力されるときにファイルロストする可能性があります。
送信側:
14084 ファイル重複のため受信拒否
受信側:
14064 未管理のため受信終了拒否
14091 ファイル重複のため受信拒否
31001 (API) 関数異常終了 [NmaGetUseFile()][22][0][0][2][par1=・・・]
|
詳細
サーバ間転送の受信側では、メールボックス間のファイルコピーが終了した後に転送ファイルの妥当性の確認やジョブ工程へファイルを渡す処理を行っています。
ここで、転送ステータスを正常終了に変更してジョブ工程へファイルを渡したあとに、転送の異常終了処理を行う場合があります。(送信側では転送異常終了)
転送は先の処理で正常終了に変更されているため、このときの異常終了へのステータス変更は次のメッセージで失敗します。
受信側:14064 未管理のため受信終了拒否
該当の転送のステータスは受信側では正常終了、送信側では異常終了(設定によって自動リトライまたは手動リトライ)となります。
受信側では異常終了処理をするときにメールボックス内のファイルを削除します。
直前に転送が正常終了になったことによりファイルはジョブ工程に渡り、ジョブがファイルを取り出そうとします。
このとき、メールボックス内のファイルは異常終了処理によって削除済みのためにファイルの取り出しでエラーとなります。
ジョブのエラーは次のメッセージが出力されます。
受信側:31001 (API)
関数異常終了[NmaGetUseFile()][22][0][0][2][par1=・・・・]
[22] NISMail側物理ファイルアクセス異常
|
送信側では送信の転送異常から手動又は自動でリトライがかかりますが、受信側では正常終了しているため、次のエラーが発生します。
送信側:14084 ファイル重複のため受信拒否
受信側:14091 ファイル重複のため受信拒否
|
送信側で上記のエラーが発生したときの動作が、Version 4.0 Release 2.7以前とVersion 4.0 Release 2.8以降で異なります。
Version 4.0 Release 2.8以降では上記エラーが発生したときに、ファイルは受信側の転送済みをもってファイルを破棄して、転送正常終了とします。このとき破棄されたファイルがロストします。次のファイルの転送は正常終了します。
ファイルは送信側のシステムから再作成する必要があります。
受信側では起動型APがファイル無しで異常終了しているため、クライアント・コントロールパネル(以降CCP)の「USE」から該当のファイルを削除しないと復旧できません。
送信側のNISMailがVersion 4.0 Release 2.7以前の場合には上記エラーが発生したときに、送信が転送異常となり転送が停滞します。
この転送異常のファイルを再処理を行うと、同一のファイルを再送しようとしますが、前回と同じエラーが再び転送異常となります。この状態はCCPのTRNから送信ファイルを削除することで復旧します。
CCPのTRNから削除すると送信ファイルが消えてしまいますので、削除前に該当のファイルをDFLQから確保して、再送します。
受信側での処理は上記と同様です。
対策
・恒久対応
根本的な問題としては、受信側の処理の不具合になります。
NISMailサービスパック(NISMail/NT Version 4.0 SP1A)の適用、もしくは NISMAIL Version 5.0へのバージョンアップで対応が可能です。
状況
弊社ではこの問題をNISMAILの問題であると認識しております。
NISMail/NT Version 4.0 Release 2.8で修正済みです
|