■Q/1台のサーバ上に複数インスタンスでNISMAILを構築しましたが、同時に動作しません。
■A/複数インスタンスで構築する場合、使用するポートを分ける必要があります。
NISMAILサーバは、1台のサーバ上に複数インスタンスで起動する事が可能です。
(NISMAIL/NTに関しては、NISMAIL/NT(x64対応) Version7.0 Release1.0以降で複数インスタンスに対応。)
同時にNISMAILが起動しないのは、複数のNISMAILで使用するポートが重なっていると考えられます。
各NISMAILで使用するポートを確認し、重なってるポートがあれば変更してください。標準で使用するポートは9001~9030です。
NISMAILの各プロセスは、NISMAILの環境定義で設定しているポートを使用します。
ポートは、1つのプロセスが使用すると他のプロセスから使用する事ができません。
ポートを使用できない場合は、プロセスは起動する事ができずに終了します。
この為、複数インスタンスで動作させるには、それぞれのNISMAILで使用するポートを重ならない様に設定する必要がございます。
ポートの変更は、バッチ型定義ツール2コマンドまたは管理コンソール(内部でバッチ型定義ツール2コマンド実行)にて行います。
バッチ型定義ツール2コマンドでサーバマネージャプロセスのポートを変更する際に、サーバマネージャプロセスが指定しているポートが使用されているとポートの変更が失敗します。
新たに作成したNISMAILのポートを変更する際に、既存のNISMAILを停止してからバッチ型定義ツール2コマンドを実行してください。
また、複数インスタンスで環境を構築する際、構築する数だけライセンスが必要となりますのでご注意ください。
|