1.4. マイグレーションアシスタント利用方法

本章はマイグレーションアシスタントツールの利用方法について紹介します。

1.4.1. 情報採取

マイグレーションアシスタントでの移行元からの情報採取は情報採取スクリプトを実行することで行います。

1.4.1.1 情報採取スクリプトの配置・展開

  1. WebOTX Developerをインストールした環境から情報採取スクリプトの 圧縮ファイルを取得し、移行元環境の任意のディレクトリに配置します。

    情報採取スクリプトの圧縮ファイルは下記ディレクトリにインストールされます。

  2. 配置した情報採取スクリプトの圧縮ファイルを展開します。

1.4.1.2 環境情報設定ファイルの編集

情報採取スクリプトの実行に必要な情報を環境情報設定ファイルに入力します。

環境情報設定ファイルは以下のパスに展開されます。

環境情報設定ファイルでは移行元のWebサーバの種類に応じてそれぞれ次の設定を入力します。

設定名 説明
AS_TYPE 移行元のAPサーバの種類を指定します。「WebOTX」または「Tomcat」を指定してください。
(例:Windowsの場合)
set AS_TYPE=WebOTX
(例:HP-UX/Linuxの場合)
AS_TYPE=Tomcat
設定名 説明
WEBOTX_INSTALL_ROOT WebOTXのインストールパスを指定します。
(例:Windowsの場合)
set WEBOTX_INSTALL_ROOT=C:\WebOTX
(例:HP-UX/Linuxの場合)
WEBOTX_INSTALL_ROOT=/opt/WebOTX
WEBOTX_DOMAINS WebOTXのドメインのリストです。半角空白で区切ります。採取対象でないドメインが存在する場合は、リストに含めないでください。
(例:Windowsの場合)
set WEBOTX_DOMAINS=WebOTXAdmin domain1
(例:HP-UX/Linuxの場合)
WEBOTX_DOMAINS="WebOTXAdmin domain1"
WEBOTX_DOMAIN_PATH_<ドメイン名> ドメインのパスです。既定(WebOTXインストールパス\domains\<ドメイン名>)から変更していない場合は定義不要です。
(例:Windowsの場合)
set WEBOTX_DOMAIN_PATH_domain1=C:\WebOTX\domains\domain1
(例:HP-UX/Linuxの場合)
WEBOTX_DOMAIN_PATH_domain1=/opt/WebOTX/domains/domain1
WEBOTX_DOMAIN_LOGIN_PARAM_<ドメイン名> ドメインのログインパラメータです。loginコマンドの引数と同じ形式です。
(例:Windowsの場合)
set WEBOTX_DOMAIN_LOGIN_PARAM_domain1=--user admin --password adminadmin --port 6212
(例:HP-UX/Linuxの場合)
WEBOTX_DOMAIN_LOGIN_PARAM_domain1="--user admin --password adminadmin --port 6212"
設定名 説明
TOMCAT_INSTALL_ROOT Tomcatのインストールパスを指定します。
(例:Windowsの場合)
set TOMCAT_INSTALL_ROOT=C:\Tomcat
(例:HP-UX/Linuxの場合)
TOMCAT_INSTALL_ROOT=/opt/Tomcat
TOMCAT_VERSION Tomcatのバージョンを指定します。
(例:Windowsの場合)
set TOMCAT_VERSION=6.0
(例:HP-UX/Linuxの場合)
TOMCAT_VERSION=7.0
TOMCAT_JDK_VERSION Tomcatで参照しているJDKのバージョンを指定します。
(例:Windowsの場合)
set TOMCAT_JDK_VERSION=1.7.0_76
(例:HP-UX/Linuxの場合)
TOMCAT_JDK_VERSION=1.7.0_76

1.4.1.3 情報採取スクリプトの実行

  1. 情報採取スクリプトを実行します。

    Caution
    情報採取スクリプトは管理者権限のあるユーザで実行してください。Windowsの場合はAdministrator権限を持つユーザ、HP-UX/Linuxの場合はrootグループに所属しているユーザです。


    Caution
    HP-UX/Linuxの場合、情報採取スクリプトを実行するプロセスのロケールをja_JP.UTF-8に設定してから採取を実行してください。


  2. 出力された設定情報圧縮ファイルをWebOTX DeveloperをインストールしたPCに保存します。
    memo
    設定情報圧縮ファイルの出力場所はスクリプト実行時のメッセージに出力されます。
    Compressing was finished. (Filename: C:\Users\Administrator\Desktop\macollector_win\bin\..\webotx_migration_configs_1603021439.zip)

1.4.2. マイグレーションプロジェクトの作成

マイグレーションプロジェクトの作成は情報採取スクリプトで収集した設定情報を元に移行先の環境に合わせた変換を行います。

メニュー ファイル > インポート を選択し、インポート ダイアログを表示します。


図1.4.2-1

インポート ダイアログで マイグレーション > 設定情報圧縮ファイル を選択して 次へ ボタンを押下すると 移行元設定情報のインポート ウィザードを表示します。


図1.4.2-2

移行元設定情報のインポート ウィザードでプロジェクト名と移行元の設定情報圧縮ファイルを入力して 次へ ボタンを押下すると 移行元設定情報の設定 ウィザードを表示します。


図1.4.2-3

移行元設定情報のインポート ウィザードで各項目の説明は下表のとおりです。

表1.4.2-1
項目 説明
プロジェクト名 ワークスペースにインポートしようとするプロジェクト名です
設定情報圧縮ファイル 情報採取スクリプトで収集した設定情報圧縮ファイル(zipファイル)のパスです

移行元設定情報の設定 ウィザードで 次へ ボタンを押下すると 移行先設定情報の設定 ウィザードを表示します。


図1.4.2-4

移行元設定情報の設定 ウィザードで各項目の説明は下表のとおりです。

表1.4.2-2
項目 説明
OSの種類 移行元環境のオペレーティングシステムの種類です
OSのバージョン 移行元環境のOSのバージョンです
CPUアーキテクチャ 移行元環境のCPUアーキテクチャです
APサーバの種類 移行元環境のAPサーバの種類です
インストールパス 移行元環境でインストールしたパスです
JDKのバージョン 移行元環境で使用したJDKのバージョンです
APサーバのバージョン 移行元環境でのAPサーバのバージョンです
エディション 移行元環境でのWebOTXサーバのエディションです
ドメイン動作モード 移行元環境でのドメインが動作するモードです
ドメイン名 移行元環境でのドメインの名称です
Webコンテナ動作モード 移行元環境でのWebコンテナの動作モードです
Webサーバの種類 移行元環境でのWebサーバの種類です
Webサーバのバージョン 移行元環境でのWebサーバのバージョンです

移行先設定情報の設定 ウィザードで各項目を設定して 終了 ボタンを押下します。


図1.4.2-5

移行先設定情報の設定 ウィザードで各項目の説明は下表のとおりです。

表1.4.2-3
項目 説明
OSの種類 移行先環境のオペレーティングシステムの種類です
OSのバージョン 移行先環境のOSのバージョンです
CPUアーキテクチャ 移行先環境のCPUアーキテクチャです
インストールパス 移行先環境でインストールしたパスです
JDKのバージョン 移行先環境で使用するJDKのバージョンを指定します。
WebOTXサーバのバージョン 移行先WebOTXサーバのバージョンを選択します。
エディション 移行先WebOTXサーバのエディションを選択します。
ドメイン動作モード 移行先環境でドメインが動作するモードを選択します。
ドメイン名 移行先環境でドメインの名称です
Webコンテナ動作モード 移行先環境でWebコンテナの動作モードです
Webサーバの種類 移行先環境でWebサーバの種類です
Webサーバのバージョン 移行先環境でWebサーバのバージョンです

進歩情報 ダイアログが表示されて実行完了後、作成したパラメータシートがパラメータシートビューで表示されます。


図1.4.2-6

これで設定情報圧縮ファイルのインポートと移行先環境に合わせた自動変換が完了しました。

1.4.3. パラメータシートの表示

パラメータシートの表示は設定情報の変換機能で変換された設定情報のパラメータシートをDeveloper上で表示します。

以下の機能が利用できます。

Caution
パラメータシートのエクセルはDeveloper上では編集は行わないでください。パラメータシートを再作成した場合、 設定ファイルの値でパラメータシートが上書きされます。

1.4.3.1. パラメータシートビュー

パラメータシートビューで表示した内容は下図のようです。


図1.4.3.1-1

パラメータシート表記

パラメータシートビューで各項目の説明は下表のとおりです。

表1.4.3.1-1
項目 説明
ツリーの一段目 ルート区分は__system__、ドメイン名、ドメイン名_移行元、インストール設定と分けています domain1,domain1_移行元,インストール設定
ツリーの二段目 運用管理ツールのツリーの二段目までのパスを表します アプリケーションサーバ/セッション構成
ツリーの三段目 運用管理ツールのツリーの三段目以降のパスを表します セッションマネージャ/マネージャプロパティ
設定名 運用管理ツールにおける設定名
既定値 デフォルト値です
設定値 設定した値です
メッセージレベル 区分はINFO、SHOULD、MUSTと分けています MUST
メッセージ メッセージの内容です。メッセージ中に改行文字がある場合は半角スペース3つに変換されます。
関連ファイル/MBean 関連ファイルがある場合にファイルパスを表し、それ以外は MBean の内容を表します config/WebServer/httpd.conf
関連ファイルの行番号です

Caution
パラメータシートビューでのメッセージの表示は256文字までとなっています。それ以上のメッセージの場合、 パラメータシートのエクセルを直接確認してください。

関連ファイルへのジャンプ

テブールビューのレコードをダブルクリックして、関連ファイルをエディタで開くことができます。


図1.4.3.1-2

行番号がある場合、エディタで対応する行番号の行に位置付きます。


図1.4.3.1-3

(1) 関連ファイル/MBean に関連ファイルのパスの先頭が「\」「/」となる場合、テブールビューのレコードをダブルクリックすると「<プロジェクト名>\ConverterResult\external\<関連ファイル>」をエディタで表示します。

(2) 関連ファイル/MBean に関連ファイルのパスの先頭が「\」「/」以外の場合、

  1. 関連ファイルが「<プロジェクト名>\ConverterResult\domain\<ドメイン名>」に存在する場合、テブールビューのレコードをダブルクリックで「<プロジェクト名>\ConverterResult\domain\<ドメイン名>\<関連ファイル>」をエディタで表示します。

  2. 関連ファイルが「<プロジェクト名>\ConverterResult\install_root」に存在する場合、テブールビューのレコードをダブルクリックで「<プロジェクト名>\ConverterResult\install_root\<関連ファイル>」をエディタで表示します。

  3. いずれもも存在しない場合、テブールビューのレコードのダブルクリックで「<プロジェクト名>\ConverterResult\mbean\mbean_<ドメイン名>.txt」をエディタで表示します。

(3) <ドメイン名>_移行元 のレコードでは関連ファイルへのジャンプは行われません。

1.4.3.2. フィルター

パラメータシートビューで▽をクリックして、メニュー パラメータシート・フィルター を選択すると パラメータシート・フィルター ダイアログが表示されます。


図1.4.3.2-1


図1.4.3.2-2

ダイアログで各項目の説明は下表のとおりです。

表1.4.3.2-1
項目 説明
デフォルトから変更があったパラメータのみ表示 テブールビューの既定値設定値が不一致のパラメータのみ表示します
メッセージレベルは「INFO」のパラメータのみ表示 テブールビューの「INFO」のパラメータのみ表示します
メッセージレベルは「SHOULD」のパラメータのみ表示 テブールビューの「SHOULD」のパラメータのみ表示します
メッセージレベルは「MUST」のパラメータのみ表示 テブールビューの「MUST」のパラメータのみ表示します
インストール設定のパラメータのみ表示 パラメータ一覧のツリーでルート「インストール設定」のパラメータのみ表示します
「関連ファイル/MBean」欄と「行」欄を非表示 テブールビューの「関連ファイル/MBean」欄と「行」欄を隠します

チェックボックス メッセージレベルは「MUST」のパラメータのみ表示 をチェックして OK ボタンを押下すると、パラメータシートビューで「MUST」のパラメータのみが表示されます。


図1.4.3.2-3

「MUST」は赤色で表示されます。確認必須のパラメータです。


図1.4.3.2-4

1.4.3.3. ファイル指定

パラメータシートビューで▽をクリックして、メニュー パラメータシート・ファイル指定 を選択すると パラメータシート・ファイル指定 ダイアログが表示されます。


図1.4.3.3-1


図1.4.3.3-2

テキストボックス パラメータシート はパラメータシートファイルのパスです。

参照 ボタンを押下すると パラメータシートの選択 ダイアログが表示されます。 この画面でマイグレーションプロジェクトに属するパラメータシートを選択することができます。


図1.4.3.3-3

パラメータシートの選択 ダイアログで OK ボタンを押下して指定したパラメータシートファイルのパスが パラメータシート・ファイル指定 ダイアログでテキストボックスに表示されます。


図1.4.3.3-4

パラメータシート・ファイル指定 ダイアログで OK ボタンを押下して指定したパラメータシートがパラメータシートビューで表示されます。


図1.4.3.3-5

1.4.3.4. パラメータシートのエクスポート

パラメータシートビューでのエクスポート を参照してください。

1.4.3.5. パラメータシートビューで開く

マイグレーションプロジェクト内のパラメータシートファイル(*.xlsx)を右クリックしメニュー パラメータシートビューで開く を選択すると、パラメータシートビューが開いていない場合は直接にパラメータシートビューを開きます。


図1.4.3.5-1

パラメータシートビューが開いている場合は確認ダイアログが表示し、OK ボタンを押下するとパラメータシートビューを開きます。


図1.4.3.5-2

1.4.3.6. パラメータシートの再作成

マイグレーションプロジェクトのプロジェクト名を右クリックしメニュー パラメータシートビューを再作成 を選択するとパラメータシートを更新します。


図1.4.3.7-1

1.4.4. パラメータシートのエクスポート

パラメータシートをエクスポートできる機能を提供します。

エクスポートウィザード

メニュー ファイル > エクスポート を選択して エクスポート ダイアログを表示します。


図1.4.4-1

エクスポート ダイアログで マイグレーション > パラメータシート > 次へ を押下してパラメータシートの エクスポート ダイアログが表示されます。


図1.4.4-2

各項目を設定して 終了 ボタンを押下するとxlsx形式のパラメータシートファイルが出力されます。


図1.4.4-3

パラメータシートの エクスポート ダイアログで各項目の説明は下表のとおりです。

表1.4.4-1
項目 説明
プロジェクト名 マイグレーションプロジェクトの名称です
宛先ファイル パラメータシートファイルを出力するパスです
ファイル拡張子:xlsx
インストールに必要な設定のみ出力 パラメータ一覧ツリーのルートインストール設定のパラメータを出力します
変更があったパラメータのみ出力 テブールビューの 既定値設定値 が不一致のパラメータを出力します
既存ファイルを上書き 宛先ファイルが存在する場合に既存ファイルを上書きして保存します
パラメータシートビューでのエクスポート

パラメータシートビューで▽をクリックして、メニュー パラメータシートをエクスポート を選択すると エクスポート ダイアログが表示されます。


図1.4.4-4


図1.4.4-5

次は エクスポートウィザードのほう と同じような操作でパラメータシートをエクスポートできます。

1.4.5. アプリケーション非互換チェック

移行されるアプリケーションに非互換コードが存在するかどうかをチェックします。

1.4.5.1 非互換チェックの実行

非互換チェックは以下の2つの方法で実行できます。

Memo
Javaプロジェクトはデフォルトでビルドする時に検証操作を行いません。 自動実行したい場合、プロジェクトの右クリックメニューの プロパティー > 検証 ページで、 プロジェクトに検証ビルダーを追加ON に設定します。

実行後、非互換コードが存在する場合、 マーカー ビューや 問題 ビューに 非互換の問題 が表示されます。


図1.4.5.1-1

指摘項目でダブルクリックすると、問題個所にジャンプされます。問題個所が選択される状態で Ctrl+1 を押すと、問題の説明やお勧めする対策が表示されます。


図1.4.5.1-2

1.4.5.2. 非互換チェックの設定

手動実行と自動実行を有効するかどうかは、ウィンドウ > 設定 > 検証 ページで設定できます。


図1.4.5.2-1

プロジェクト個別で設定したい場合、プロジェクトの右クリックメニューの プロパティー > 検証 ページで設定します。


図1.4.5.2-2

非互換チェックのメッセージ出力レベルを制御するため、ウィンドウ > 設定 > WebOTX > マイグレーション > エラー/警告 ページで設定できます。


図1.4.5.2-3

上記画面でカテゴリのチェックボックスを ON にすると、該当カテゴリ内のチェック規則が実行されます。チェックボックスを OFF にすると、該当カテゴリ内のチェック規則が実行されません。

チェック規則個別にも設定できます。


図1.4.5.2-4

エラー を選択すると、該当チェック規則が実行され、エラーメッセージが出力されます。
警告 を選択すると、該当チェック規則が実行され、警告メッセージが出力されます。
情報 を選択すると、該当チェック規則が実行され、情報メッセージが出力されます。
無視 を選択すると、該当チェック規則が実行されません。

1.4.6. 関連アプリケーションの指定

マイグレーションプロジェクトのプロパティの関連アプリケーションページで関連アプリケーションのプロジェクトの設定機能を提供します。

アプリケーションをマイグレーションプロジェクトに追加する方法について
(1) 変更が必要でリビルドしたい場合

マイグレーションプロジェクトの 関連アプリケーションのプロジェクト指定 機能を利用し、アプリケーションの関連プロジェクトが指定できます。

マイグレーションプロジェクト名を選択し、右クリックメニュー プロパティー を選択すると プロパティー ダイアログが表示されます。


図1.4.6-1

プロパティー ダイアログで 関連アプリケーション を選択し、関連アプリケーションページを表示します。


図1.4.6-2

各項目の説明は下表のとおりです。

表1.4.6-1
項目 説明
ドメイン名 ドメインの名称です
アプリケーション名 アプリケーションの名称です
アプリケーションタイプ アプリケーションのタイプです(WEB,JAVAEEなど)
プロジェクト名 関連アプリケーションのプロジェクト名です

レコードを選択して 編集 ボタンを押下すると、関連アプリケーションの情報 ダイアログが表示されます。


図1.4.6-3

プロジェクト名 のテキストボックスで入力するか 参照 ボタンを利用して、アプリケーションの関連プロジェクトを指定し、OK ボタンを押下して、プロパティー ダイアログに戻ります。

該当アプリケーションが対応する プロジェクト名 に指定されたプロジェクト名が表示されます。


図1.4.6-4

プロパティー ダイアログで OK ボタンを押下して、関連アプリケーションの設定が完了します。

関連アプリケーションのプロジェクトの対応一覧は下表のとおりです。

表1.4.6-2
アプリケーションのタイプ 表示値 プロジェクトのタイプ
Java EEアプリケーション JAVAEE エンタープライズ・アプリケーション・プロジェクト
EJBアプリケーション EJB EJB プロジェクト
Webアプリケーション WEB 動的 Web プロジェクト
リソースアダプタ RESOURCE コネクター・プロジェクト
アプリケーションクライアントコンポーネント APP_CLIENT アプリケーション・クライアント・プロジェクト
CORBAアプリケーション Java CORBA_JAVA 任意プロジェクト(※「CORBA/共有アプリケーションのプロジェクト作成」を参照してください。)
CORBAアプリケーション C++ CORBA_C
共有コンポーネント Java SHARED_JAVA
共有コンポーネント C++ SHARED_C

CORBA/共有アプリケーションのプロジェクト作成

1) 一般なプロジェクトを新規で作成します。


図1.4.6-5



図1.4.6-6



図1.4.6-7



図1.4.6-8



2) 移行元のCORBA/共有アプリケーションの*.jar, *.if, *.properties, *.dll, *.soファイルを該当プロジェクトの配下にコピーします。


図1.4.6-9



コピーするファイルは以下の表のとおりです。

表1.4.6-3
アプリケーションのタイプ コピーするファイル
CORBAアプリケーション Java *.jar [必須]
*.if [任意]
*.properties [任意]
共有コンポーネント Java
CORBAアプリケーション C++ *.dll [OSの種類 がWindowsの場合に必須]
*.so [OSの種類 がWindows以外の場合に必須]
*.if [任意]
*.properties [任意]
共有コンポーネント C++
(2) 変更不要でリビルドがない場合

マイグレーションプロジェクトのアプリケーション保存フォルダに手動でコピーしてください。

アプリケーション本体ファイルの保存位置は下記のとおりです。

<プロジェクト名>\ConverterResult\application\ドメイン名\<アプリケーション名>\<アプリケーション本体ファイル>

表1.4.6-4
アプリケーションのタイプ 本体ファイルのタイプ
Java EEアプリケーション *.ear
EJBアプリケーション *.jar
Webアプリケーション *.war
リソースアダプタ *.rar
アプリケーションクライアントコンポーネント *.jar
CORBAアプリケーション Java *.cpk
CORBAアプリケーションC++ *.cpk
共有コンポーネント Java *.spk
共有コンポーネント C++ *.spk

Caution
移行元環境でdeploydirで配備(ディレクトリ構造のままの配備方法)されていたアプリケーションの場合、 ディレクトリ構造をjarコマンドで圧縮した形でアプリケーションフォルダに配置してください。

Caution
Linux のC++ CORBAアプリケーションを移行する場合、gcc 3.xとgcc 4.xのバイナリ非互換のため、 gcc 3.x でビルドされているアプリケーションは必ず gcc 4.x で再ビルドする必要があります。 gcc 4.x で再ビルドを行わない場合、正しく移行されません。

1.4.7. マイグレーションプロジェクトのエクスポート

メニューファイル > エクスポート を選択すると エクスポート ダイアログが表示されます。


図1.4.7-1

マイグレーション > 設定情報圧縮ファイル を選択し、 次へ を押下します。


図1.4.7-2

設定情報の エクスポート ダイアログが表示されます。


図1.4.7-3

各項目の説明は下表のとおりです。

表1.4.7-1
項目 説明
プロジェクト名 マイグレーションプロジェクトの名称を指定します。
宛先ファイル エクスポート先ファイルのパスを指定します。
システムの設定 エクスポートしたファイルにシステム単位の設定を含めるかどうかを指定します。
選択:エクスポートする
非選択:エクスポートしない
ドメインとアプリケーションツリー エクスポートしたファイルに含めるドメインとアプリケーションを指定します。
選択する場合、対応するアプリケーションがエクスポートしたzipファイルのConverterResult\applicationに保存されます。
ドメイン全選択 ドメインとアプリケーションを全て選択します。
ドメイン全解除 ドメインとアプリケーションの選択を全て解除します。
ドメインの名前変更 エクスポートする際に、ドメイン名を変更するかどうかを指定します。
選択:ドメイン名を変更する
非選択:ドメイン名を変更しないで、移行元のdomain名をそのまま利用する
変更元 変更前のドメイン名を指定します。
変更先 変更後のドメイン名を指定します。
編集 ドメインの名前変更 ダイアログでドメイン名の変更先を指定します。
既存ファイルを上書き 宛先ファイルが存在した場合に上書きして保存するかどうかを指定します。
選択する場合、宛先ファイルが存在した場合に上書きして保存します。
パラメータシートを再作成 エクスポート前にパラメータシートを再作成するかどうかを指定します。
選択した場合、パラメータシートを再作成してから、エクスポート処理を行います。

設定情報の エクスポート ダイアログで 終了 ボタンを押下すると、マイグレーションプロジェクトをzipファイルにエクスポートします。

1.4.8. 設定情報の配備

移行先の設定情報圧縮ファイルをインポート時に変換した設定情報を移行先サーバに配備する機能を提供します。また、設定情報にはアプリケーションに対して設定するものも含まれるため、アプリケーションに対する設定も一度に反映させるためにアプリケーションも同時に配備し設定できる機能を提供します。

設定情報を移行先サーバに配備する方法は以下の2つです。

(1) 移行先サーバに配備

マイグレーションプロジェクトのプロジェクト名を選択し、右クリックメニュー 実行 > 移行先サーバに配備 を選択します。


図1.4.8-1

移行先サーバに配備 ダイアログが表示されます。


図1.4.8-2

各項目の説明は下表のとおりです。

表1.4.8-1
項目 説明
プロジェクト名 マイグレーションプロジェクトの名称を指定します。
ホスト 移行先サーバのホスト
ドメイン名 移行先サーバの管理ドメインの名前
ユーザ名 移行先サーバの管理ドメインのユーザ名
パスワード 移行先サーバの管理ドメインのパスワード
ポート 移行先サーバの管理ドメインのポート
システムの設定 システム単位の設定を配備するかどうかを指定します。
選択:配備する
非選択:配備しない
ドメインとアプリケーションツリー 配備するドメインとアプリケーションを指定します。
ドメイン全選択 ドメインとアプリケーションを全て選択します。
ドメイン全解除 ドメインとアプリケーションの選択を全て解除します。
ドメインの名前変更 移行先サーバへ配備する際に、ドメイン名を変更するかどうかを指定します。
選択:ドメイン名を変更する
非選択:ドメイン名を変更しないで、移行元のdomain名をそのまま利用する
変更元 変更前のドメイン名を指定します。
変更先 変更後のドメイン名を指定します。
編集 ドメインの名前変更 ダイアログでドメイン名の変更先を指定します。
既存ファイルを上書き 宛先ファイルが存在した場合に上書きして保存するかどうかを指定します。
選択する場合、宛先ファイルが存在した場合に上書きして保存します。
パラメータシートを再作成 エクスポート前にパラメータシートを再作成するかどうかを指定します。
選択した場合、パラメータシートを再作成してから、エクスポート処理を行います。

移行先サーバに配備 ダイアログで各項目を設定して、終了 ボタンを押下して、移行先サーバの配備を行います。

(2) 実行構成ダイアログでの実行

マイグレーションプロジェクトのプロジェクト名を選択し、右クリックメニュー 実行 > 実行の構成 を選択します。


図1.4.8-3

実行構成 ダイアログが表示されます。
WebOTX移行 を選択し、新規の起動構成 を押下することで、新規構成 さ作成されます。

管理ドメインの設定 および 配備タイプ タグで各項目を設定して、適用 ボタンを押下して、各設定を保存します。実行 ボタンを押下して、移行先サーバの配備を行います。

管理ドメインの設定 タブ:


図1.4.8-4

配備タイプタブ:


図1.4.8-5

管理ドメインの設定 および 配備タイプ タグで各項目の説明は表1.4.8-1 を参照してください。

1.4.8.1. 設定情報の配備のパラメータ

以下のファイル名のプロパティファイルを格納することで、設定情報の配備の動作に関する設定を行うことができます。


以下は指定可能なパラメータの一覧です。

プロパティ名 説明 既定値
domain.operation.timeoutSeconds 設定情報の配備処理中に行うドメイン起動・停止処理のタイムアウトです。ドメインに多数のアプリケーションが配備されている等、ドメインの起動・停止に時間がかかることが想定される場合は、このプロパティに適切な値を設定してタイムアウトを延長してください。 1800(秒)