6.1. シンプルポートレット

6.1.1. 概要

Portlet API に準拠した非常に単純なJavaポートレットです。
ポートレットのコンテンツに文字列を出力する方法について確認することができます。


図6.1.1-1

6.1.1.1. 作成の流れ:

  1. ポートレットプロジェクトウィザードを利用し、プロジェクトを作成
  2. ポートレットウィザードを利用し、ポートレットを作成
  3. JavaファイルのdoViewメソッドに「Hello World!」の出力処理を追加

6.1.2. 構成

表6.1.2-1
ファイル名 説明
SimplePortlet.zip 「Hello world」を出力するポートレット

6.1.3. 実行手順

実行環境の構築を行い、サンプルを実行します。実行後には環境のクリアを行います。

6.1.3.1. 配備

サンプルをインポートして、ポータルサーバへの配備を行います。
  1. SimplePortlet.zipを適当なディレクトリに保存します。
  2. Developer's Studioを起動します。
  3. メニューからファイル > インポート を選択します。


    図6.1.3.1-1

  4. 既存プロジェクトをワークスペースへ を選択し、次へ をクリックします。


    図6.1.3.1-2

  5. アーカイブ・ファイルの選択 を選択し、ダウンロードしたSimplePortlet.zipを指定します。完了 をクリックして、サンプルのプロジェクトをインポートします。


    図6.1.3.1-3

  6. プロジェクトをインポートしたら、パッケージエクスプローラからプロジェクトを右クリックし、実行 > サーバーで実行 を選択します。


    図6.1.3.1-4

  7. 配備先のサーバーを選択し、完了 をクリックします。新規にポータルサーバーを作成したい場合は、2.18. ポートレットの配備 を参照してください。Developer's Studioによる配備を行うと、配備した物件の起動も同時に行われます。


    図6.1.3.1-5

6.1.3.2. ポートレット追加

  1. ポータルのログイン画面が表示されたら、ユーザ名とパスワードを入力して、ログインします。テスト用サーバを利用する場合のユーザ名及びパスワードは (USER0000/空白以外の任意文字) です。


    図6.1.3.2-1


  2. ログインした後、編集モードに切り替えてからポートレットライブラリ をクリックします。


    図6.1.3.2-2


  3. 表示されたポートレットライブラリのダイアログにおいて、左側のカタログタブを選択し、 右下に表示される新規ポートレット作成ボタンをクリックします。


    図6.1.3.2-3


  4. テンプレートに表示されるポートレット一覧から、対象のポートレットを選択し、OK をクリックします。
    これにより選択したポートレットがポートレットライブラリに新規作成されます。


    図6.1.3.2-4


  5. 表示されたポートレットのプロパティダイアログにおいて、OK をクリックします。


    図6.1.3.2-5


  6. 作成ポートレット をクリックして作成したポートレットの一覧を表示します。
    表示されているポートレット名の右側にある追加ボタンをクリックすると、選択したポートレットがポータルページに追加されます。


    図6.1.3.2-6


6.1.3.3. ポートレット実行

  1. ポートレットがページに追加されると、ポートレットのコンテンツとして「Hello World!」を表示します。


    図6.1.3.3-1


6.1.3.4. ポートレット削除

  1. ポータルページからポートレットを削除するには、編集モードでポートレットのタイトルバーの右端にあるポートレット削除ボタンを押下してください。


    図6.1.3.4-1


  2. ポートレットの削除確認画面が表示されたら、「削除する」ボタンを押して処理を適用します。


    図6.1.3.4-2


  3. ポートレットデータ自体を削除するには、編集モードで ポートレットライブラリ をクリックします。


    図6.1.3.4-3


  4. 表示されたポートレットライブラリのダイアログにおいて、左側のカタログタブを選択し、 作成ポートレット をクリックしてポートレットの一覧を表示させます。


    図6.1.3.4-4


  5. 表示されているポートレット名の左側にあるラッチボタンをクリックし、右下に出てくるカタログから削除ボタンをクリックします。


    図6.1.3.4-5


  6. 削除の確認を行うダイアログが表示されますので、OKボタンをクリックします。 これによりポータルに作成されたポートレットが削除されます。


    図6.1.3.4-6


6.1.3.5. 配備解除

配備したサンプルを配備解除します。
  1. Developer's Studioのメニューから、ウィンドウ > ビューの表示 > サーバー を選択します。


    図6.1.3.5-1


  2. 表示されたサーバーのビューから配備したアプリケーションを右クリックし、除去を選択します。


    図6.1.3.5-2


6.1.4. 関連トピック

2.3. ポートレットプロジェクト
2.4. ポートレットウィザードの利用

6.1.5. 注意事項

特になし。