ページの先頭です。
サイト内の現在位置を表示しています。
  1. ホーム
  2. ソフトウェア
  3. WebOTX
  4. アプリケーションサーバ
  5. 動作環境
  6. V8.4 Solaris版 対応データベース(Java)
ここから本文です。

WebOTX Application Server V8.4 Solaris版 対応データベース(Java)

WebOTX Application Serverは、JDBC 2.0~JDBC 4.0の仕様に準拠しているJDBCドライバを介して任意のDBMSへの接続をサポートするように設計されています。

アプリケーションが独自の方式でデータベース・サーバに接続したり、WebOTX Application Serverが提供するJDBCデータソースによる接続、あるいは、WebOTX Application ServerのTransactionサービス機能と連携したJTAトランザクションを使用する場合には、データベース・サーバ製品にバンドルされるJDBCドライバを入手して、セットアップしなければなりません。WebOTX Application Serverでは以下のJDBCベンダのJDBCドライバについて動作確認済みです。

  • Oracle9i Database Release 2 (9.2.0)
  • Oracle Database 10g Release 1 (10.1.0)
  • Oracle Database 10g Release 2 (10.2.0)
  • Oracle Database 11g Release 1 (11.1.0)
  • Oracle Database 11g Release 2 (11.2.0)
  • DB2 Universal Database 8.1.4
  • DB2 V9.1
  • DB2 V9.7
  • Microsoft SQL Server 2000
  • Microsoft SQL Server 2005
  • Microsoft SQL Server 2008
  • Microsoft SQL Server 2012
  • Sybase Adaptive Server Enterprise 12.5
  • DataDirect Connect for JDBC 3.3以降によるOracle接続
  • SequeLink for JDBC 5.0によるOracle接続
  • PostgreSQL 7.3.2
    (JDBCドライバ 7.3 Build 113) ~ 9.0.8 (JDBCドライバ 9.0 Build 802)
    (JTA 連携を行う場合はバージョン8.1.0以降)
  • Cloudscape 3.0.3
    (J2EE 1.3.1 SDKにバンドルされるもの)
  • Apache Derby 10.2.2 ~ 10.5.3
  1. WebOTX ASは、Java EE 5仕様互換性テスト・パッケージ(J2EE CTS)を「Connect for JDBC 3.5」と「Oracle 10g」の組み合わせでパスしています。その他の製品についてもJDBC 2.0 ~JDBC 4.0の仕様に準拠しているJDBCドライバであれば、WebOTX ASと連携して使用することができます。ただし、十分な評価を行ってください。
  2. Oracle Real Application Cluster (RAC)とX/Open XAの機能を利用して2フェーズコミットを行うためには、必ず次のパッチを適用してください。
    • PSR 9.2.0.7
    • PSR 10.1.0.3

    パッチの詳細についてはOracle社の情報をご参照ください。
  3. PostgreSQLを使用して2フェーズコミットを行う場合には、PostgreSQL 8.1と、バージョン8.1-404以降のJDBCドライバを使用してください。
  4. PostgreSQL 9.0.8 / DB2 V9.7についてはWebOTX Media V8.5からインストールした場合のみサポートします。

ページの先頭へ戻る