ページの先頭です。
サイト内の現在位置を表示しています。
  1. ホーム
  2. ソフトウェア
  3. WebOTX
  4. アプリケーションサーバ
  5. 動作環境
  6. V8.2 HP-UX版
ここから本文です。

WebOTX Application Server V8.2 HP-UX版 動作環境

WebOTX Application Server Express

ハードウェア 本体 NX7700iシリーズ
メモリ容量

最小1GB以上、推奨1.5GB以上

必要HDD容量 300MB以上
ソフトウェア OS Itanium 2
HP-UX 11i v2 (11.23)
HP-UX 11i v3 (11.31)
(※)必須OSパッチ

  1. PHSS_31856 s700_800 11.23 linker + fdp cumulative patch リンカーの不具合により、メモリリーク障害が発生します。
  2. PHCO_34944 s700_800 11.23 pthread library cumulative patch pthreadライブラリの不具合により、ドメイン停止などの障害が発生する場合があります。
その他 Java™ Platform, Standard Edition
J2SE 5.0
Java SE 6
  1. HP-UXプラットフォームでは、ベンダーからSDKの動作に必要なOSパッチが付属ドキュメントに記載されています。パッチ未適用による品質や性能の低下、劣化を防止するために、WebOTX Application Server導入時にOSパッチの適用状況を確認し、SDKの動作で必要とされる全てのOSパッチを適用しておくことを強く推奨します。
  2. IPv6ネットワーク環境では、1.5.0.08以降をサポートします。
  3. HP-UXのSDK 5.0は、メンテナンス・バージョン 02 (5.0.02) 以降をサポートします。また、Java SE 6 は、HP JDK 6.0.4以降をサポートします。それより前のバージョンは、SDKの問題により動作に問題があることが確認されています。
  4. HP-UXプラットフォームは、NX7700iシリーズで提供する「HP Javaサポートサービス」に契約していただくことでJava SDKの保守サポートを受けることができます。その他、基幹システム向けに運用性、保守性を向上させた「Mission Critical Javaプロダクトサポート」も用意しています。
Webブラウザ・プラグイン
WebOTX実行環境を管理するためにブラウザベースの管理ツールとして、Web版統合運用管理コンソールを提供しています。Web版統合運用管理コンソール(Ajax)を使用するには、Internet Explorer 6/7またはFireFox 2/3が必要です。
また、複数ドメインの管理のために、従来提供していたAdobe Flash を使用したWeb版統合運用管理コンソールも提供しています。動作条件としてAdobe Flash Playerプラグインが必要です。
運用管理コンソールで統計情報のグラフを表示するためには、WebブラウザにWebOTX Application ServerでサポートしているJ2SEと同バージョンのJREが必要です。

Webサーバ
  • WebOTX Webサーバ (*1)
  • Apache HTTP Server 2.0.63/2.2.11以降
  • Sun Java System Web Server 6.1、7.0 (*2)
  1. WebOTX Webサーバは、WebOTX にバンドルされている Apache ベース(Apache HTTP Server 2.0.63/2.2.11以降)の Webサーバです。
  2. Intel Itaniumプロセッサを搭載したシステム用のOSは、Webサーバ製品が動作対象にしていません。そのため、WebOTXも未サポートになります。未サポートOSは下記のとおりです。
    • NX7700iシリーズ HP-UX 11i v2, 11i v3
データベース
WebOTX Application Serverは、JDBC 2.0~JDBC 4.0の仕様に準拠しているJDBCドライバを介して任意のDBMSへの接続をサポートするように設計されています。アプリケーションが独自の方式でデータベース・サーバに接続したり、WebOTX Application Serverが提供するJDBCデータソースによる接続、あるいは、WebOTX Application ServerのTransactionサービス機能と連携したJTAトランザクションを使用する場合には、データベース・サーバ製品にバンドルされるJDBCドライバを入手して、セットアップしなければなりません。WebOTX Application Serverでは以下のJDBCドライバについて動作確認済みです。

  • Oracle9i Database Release 2 (9.2.0)
  • Oracle Database 10g Release 1 (10.1.0)
  • Oracle Database 10g Release 2 (10.2.0)
  • Oracle Database 11g Release 1 (11.1.0)
  • DB2 Universal Database 8.1.4
  • DB2 V9.1
  • Microsoft SQL Server 2000
  • Microsoft SQL Server 2005
  • Microsoft SQL Server 2008
  • Sybase Adaptive Server Enterprise 12.5
  • DataDirect Connect for JDBC 3.3以降によるOracle接続
  • SequeLink for JDBC 5.0によるOracle接続
  • PostgreSQL 7.3.2 (JDBCドライバ 7.3 Build 113) ~ 8.3.1 (JDBCドライバ 8.3 Build 603)
    (JTA 連携を行う場合はバージョン8.1.0以降)
  • Cloudscape 3.0.3 (Sun J2EE 1.3.1 SDKにバンドルされるもの)
  • Apache Derby 10.2.2 ~ 10.4.2
  1. WebOTX ASは、Java EE 5仕様互換性テスト・パッケージ(J2EE CTS)を「Connect for JDBC 3.5」と「Oracle 10g」の組み合わせでパスしています。その他の製品についてもJDBC 2.0 ~JDBC 4.0の仕様に準拠しているJDBCドライバであれば、WebOTX ASと連携して使用することができます。ただし、十分な評価を行ってください。
  2. PostgreSQLを使用して2フェーズコミットを行う場合には、PostgreSQL 8.1と、バージョン8.1-404のJDBCドライバを使用してください。
  3. Oracle Real Application Cluster (RAC)とX/Open XAの機能を利用して2フェーズコミットを行うためには、必ず次のパッチを適用してください。
    • PSR 9.2.0.7
    • PSR 10.1.0.3
    パッチの詳細についてはOracle社の情報をご参照ください。

WebOTX Application Server Foundation

ハードウェア 本体 NX7700iシリーズ
メモリ容量 最小1.5GB以上、推奨2GB以上
必要HDD容量 400MB以上
ソフトウェア OS Itanium 2
HP-UX 11i v2 (11.23)
HP-UX 11i v3 (11.31)
(※)必須OSパッチ

  1. PHSS_31856 s700_800 11.23 linker + fdp cumulative patch リンカーの不具合により、メモリリーク障害が発生します。
  2. PHCO_34944 s700_800 11.23 pthread library cumulative patch pthreadライブラリの不具合により、ドメイン停止などの障害が発生する場合があります。
  3. PHNE_39203 11.31 cumulative ARPA Transport patch WebOTX起動時にマシンが再起動する場合があります。
その他 Expressと同様

WebOTX Application Server Standard / for Standby System

ハードウェア 本体 NX7700iシリーズ
メモリ容量 最小1.5GB以上、推奨2GB以上
必要HDD容量 500MB以上
ソフトウェア OS Foundationと同様
その他 Java™ Platform, Standard Edition
Expressと同様
Webブラウザ・プラグイン
Expressと同様
Webサーバ
Expressと同様
データベース
<Java>
Expressと同様
<CORBA C++>
Transactionサービスをご使用になる場合の対応データベース、メッセージングミドルウェアは以下のとおりです。
  • Oracle9i Database Release 2 (9.2.0)
  • Oracle Database 10g Release 1 (10.1.0)
  • Oracle Database 10g Release 2 (10.2.0)
  • Oracle Database 11g Release 1 (11.1.0)
TPモニタが提供するデータベース自動接続機能を使ってCORBA C++モジュールを構築する場合は、Oracleデータベースのみをサポートし、Oracle9i R9.2.0 以降が利用可能です。

  1. Oracle Real Application Cluster (RAC)とX/Open XAの機能を利用して2フェーズコミットを行うためには、必ず次のパッチを適用してください。
    • PSR 9.2.0.7
    • PSR 10.1.0.3
  2. パッチの詳細についてはOracle社の情報をご参照ください。

WebOTX Application Server Enterprise / for Standby System

ハードウェア 本体 NX7700iシリーズ
メモリ容量 最小1.5GB以上、推奨2GB以上
必要HDD容量 500MB以上
ソフトウェア OS Foundationと同様
その他 Standardと同様

WebOTX Developer

ハードウェア 本体 NX7700iシリーズ
メモリ容量 最小 128MB、推奨 256MB以上
必要HDD容量 300MB以上
ソフトウェア OS Expressと同様
その他 C++開発環境
  • C++コンパイラとして、「ANSI C++ A.05.xx及び、A.06.xx」が必要

WebOTX Administrator

ハードウェア 本体 NX7700iシリーズ
メモリ容量 最小 48MB、推奨 64MB以上
必要HDD容量 90MB以上
ソフトウェア OS Expressと同様
その他 Java™ Platform, Standard Edition
Expressと同様

WebOTX Download Contents

ハードウェア 本体 NX7700iシリーズ
メモリ容量 128MB以上
必要HDD容量 70MB 以上
ソフトウェア OS Expressと同様
その他 Webサーバ
Expressと同様

WebOTX Object Broker C++

ハードウェア 本体 NX7700iシリーズ
メモリ容量 256MB以上
必要HDD容量 280MB
ソフトウェア OS Expressと同様
その他

WebOTX Object Broker Java

ハードウェア 本体 NX7700iシリーズ
メモリ容量 256MB以上
必要HDD容量 150MB以上
ソフトウェア OS Expressと同様
その他 Java™ Platform, Standard Edition
J2SE 1.4.2
J2SE 5.0
Java SE 6
  1. HP-UXプラットフォームでは、ベンダーからSDKの動作に必要なOSパッチが付属ドキュメントに記載されています。パッチ未適用による品質や性能の低下、劣化を防止するために、WebOTX Application Server導入時にOSパッチの適用状況を確認し、SDKの動作で必要とされる全てのOSパッチを適用しておくことを強く推奨します。
  2. IPv6ネットワーク環境では、1.5.0.08以降をサポートします。
  3. HP-UXのSDK 5.0は、メンテナンス・バージョン 02 (5.0.02) 以降をサポートします。また、Java SE 6 は、HP JDK 6.0.4以降をサポートします。それより前のバージョンは、SDKの問題により動作に問題があることが確認されています。
  4. HP-UXプラットフォームは、NX7700iシリーズで提供する「HP Javaサポートサービス」に契約していただくことでJava SDKの保守サポートを受けることができます。その他、基幹システム向けに運用性、保守性を向上させた「Mission Critical Javaプロダクトサポート」も用意しています。

WebOTX Cluster

ハードウェア 本体 NX7700iシリーズ
メモリ容量 512MB以上、推奨 768 MB以上
必要HDD容量 128MB以上
ソフトウェア OS Expressと同様
その他 Java™ Platform, Standard Edition
Expressと同様

WebOTX WebAP JSP

ハードウェア 本体 NX7700iシリーズ
必要メモリ容量 512MB以上
必要HDD容量 2MB以上
ソフトウェア OS HP-UX 11i v2 (11.23) 2004年9月版以降
HP-UX 11i v3
その他 Java 2 SDK, Standard Edition (J2SE)
  • J2SE 5.0
  • J2SE 6.0

  1. JREのみは不可、JRun付属のJDKは不可
Webサーバ
  • WebOTX Webサーバ2.0/2.2

Servletコンテナ
  • WebOTX Webコンテナ5.0

Webブラウザ
推奨
  • Netscape 6以上
  • Internet Explorer 5.0以上

MFDL移行したWebアプリケーションでは、使用可能なWebブラウザは以下のとおりです。

  • Internet Explorer 5.0
  • Internet Explorer 5.5
  • Internet Explorer 6
  • Internet Explorer 7
  • Netscape Communicator 4.5
  • Netscape Communicator 4.7
  • Netscape 6
  • Netscape 7

MFDL移行したWebアプリケーションの場合、Netscapeでは一部使用できない機能があるので、Internet Explorerの使用を推奨します。

その他
  • Object Broker実行環境10.x

ページの先頭へ戻る