ページの先頭です。
サイト内の現在位置を表示しています。
  1. ホーム
  2. 製品
  3. 企業・官公庁向け製品名一覧
  4. UNIVERGE IXシリーズ
  5. 技術情報/お知らせ
  6. 障害切り分けガイドライン
  7. 2章 QoSでの障害切り分け方法 事例1
ここから本文です。

UNIVERGE IXシリーズ 障害切り分けガイドライン

2章 QoSでの障害切り分け方法

事例1 パケットが分類されない

QoSによる分類が正常に動作しているかを調査します。
確認ポイントに沿って確認を行います。

確認ポイント

  1. 各設定の関連付けは出来ているか
  2. match条件の定義は問題ないか
  3. クラスマップの評価順序を考慮した設定となっているか

各設定の関連付けは出来ているか

QoSの設定では、アクセスリスト、クラスマップ、ポリシーマップを適切に関連付けする必要があります。

■確認コマンド
Router(config)# show running-config

class-map match-any class-pq(A)
 
policy-map outmap(B)

class class-pq(A)

interface GigaEthernet0.0
service-policy enable
service-policy output outmap(B)

クラスマップとポリシーマップの関連付けを確認します(A)
ポリシーマップとインターフェースの関連付けを確認します(B)

ip access-list pq-list(C) permit ip src 192.168.1.1/32 dest any

class-map match-any class-pq

match ip access-list pq-list(C) high

アクセスリストを使用している場合は、アクセスリストの関連付けを確認します(C)

アクセスリストとクラスマップの関連付けで良くある間違いを紹介します。

ip access-list(D) pq-list permit ip src 192.168.1.1/32 dest any

class-map match-any class-pq

match access-list(D) pq-list high

上の設定では、アクセスリストは「IPアクセスリスト」、クラスマップでは「MACアクセスリスト」を指定しています(D)
IXルータのmatch条件では「IPアクセスリスト」と「MACアクセスリスト」の2種類のアクセスリストを使用することができますので、指定しているアクセスリストの種類にも注意が必要です。

match条件の定義は問題ないか

クラスマップの判定条件には、「match-all」と「match-any」の2種類があります。

(1)「match-all」(AND条件)による判定

matchコマンドで指定した条件に全て一致している通信が指定のクラスマップに分類されます。
CBQやLLQなど複数のクラス使う際に使用します。

  • class-map match-all class-a
  • match ip access-list cbq-list normal
  • match input-interface GigaEthernet1:1.0 normal

上の設定の場合、IPアクセスリスト(cbq-list)の条件に一致する通信で、かつ、「GigaEthernet1:1.0」のインタフェースで受信した通信が、class-aのクラスに分類されます。

(2)「match-any」(OR条件)による判定

matchコマンドで指定した条件のいずれか1つにさえ一致していれば、指定のクラスに分類されます。
クラスマップ内の各条件毎に優先度(PQ)を設定したい場合に使用します。

  • class-map match-any class-a
  • match ip access-list pq-list high
  • match local-generate-packet medium
  • match input-interface GigaEthernet1:1.0 normal
  • match any low

上の設定の場合、class-aのクラスに分類された通信は、一致した条件に設定されている優先度に応じて出力されます。

- IPアクセスリスト(pq-list)に一致する通信:第1優先
- ルータ内部で生成したパケットを指定クラスに分類:第2優先
- 「GigaEthernet1:1.0」のインタフェースで受信した通信:第3優先
- その他の通信:第4優先

■注意点

IXルータではクラスマップの判定条件を省略することができます。クラスマップの判定条件を省略した場合、「match-all」で動作を行います。

クラスマップの評価順序を考慮した設定となっているか

(A)クラスマップ内の評価は、"show running-config"で表示された順に行われます。

「match any」等の全ての通信を対象とする条件は、クラスマップの最後の行(★)に設定していただく必要がございます。

(誤)

  • class-map match-any class-pq
  • match any low <==★
  • match ip access-list pq-list high
  • match input-interface GigaEthernet1:1.0 normal


(正)

  • class-map match-any class-pq
  • match ip access-list pq-list high
  • match input-interface GigaEthernet1:1.0 normal
  • match any low <==★

上の(誤)の設定では、全ての通信が「match any」の条件に一致してしまうため、「match any」以降の条件が評価されません。

(B)ポリシーマップ内のクラスマップの評価も、"show running-config"で表示された順に行われます。

「match any」等の全ての通信を対象とする条件を設定しているクラスマップは、ポリシーマップ内でも一番最後(★)に設定する必要があります。

(誤)

  • class-map match-all class-a
  • match ip access-list cbq-list normal
  • !
  • class-map match-all class-b
  • match any nomal
  • !
  • policy-map outmap
  • class class-b <==★
  • bandwidth percent 70
  • class class-a
  • bandwidth percent 30
 
(正)
  • class-map match-all class-a
  • match ip access-list cbq-list normal
  • !
  • class-map match-all class-b
  • match any normal
  • !
  • policy-map outmap
  • class class-a
  • bandwidth percent 70
  • class class-b <==★
  • bandwidth percent 30

上の(誤)の設定では、"class-a"より先に「match any」を指定した"class-b"が評価されるため、"class-a"の評価は行われません。

← 目次へ← 事前確認へ | 事例2へ →

ページの先頭へ戻る